ElecNet Manual
for modeling ECT sensors

Written by Dr. Kostadin Brandisky, 2010

Lecture 1

Introduction
ElecNet v7 is a 2D/3D electric field simulation software, based on the Finite Element Method (FEM). It is developed by the Canadian company Infolytica. ElecNet solves static, AC (time-harmonic) and transient electric field and current flow problems.

Using ElecNet, the designers can model complicated devices and accurately predict their behavior. ElecNet can analyze the performance of many electrical engineering devices, e.g.:

- Shielding
- Cables
- Capacitive Sensors
- High Voltage Components
- Insulation Systems
- Transformers
- EMC Compatibility

Main features of ElecNet
ElecNet can solve:
1. Static electric fields
   - Simulates static electric fields produced by specified DC voltages and charge distributions
   - Supports “floating” conductors (the “floating” conductor is at one potential, but its value is initially unknown).

2. Current Flow
   - Simulates the DC current distribution produced by specified DC voltages on electrodes in contact with conducting material

3. AC or Time Harmonic electric fields
   - Simulates electric fields produced by specified AC voltages
   - Analysis based on a single frequency using phasors (complex domain)
   - Accounts for displacement currents (capacitive currents)
   - Supports floating conductors
   - Electrical conduction and lossy dielectrics

4. Transient or Time-varying electric fields
   /not present in the configuration purchased and will not be considered here/
   - Simulates transient electric fields produced by transient voltages
   - Non-linear permittivity and conductivity
• Accounts for displacement currents
• Supports floating conductors
• Electrical conduction and lossy dielectrics
• Second-order time stepping
• Resume Feature: pause at a particular time step for inspection

Additional features:
The ElecNet solvers support
• Windows® XP and Vista 32-bit and 64-bit
• All 3D solvers are multithreaded for true multicore support
• Symmetry for reducing solution domain
• Optimization with OptiNet (not purchased)

Results
• Electric field intensity \((E)\)
• Electric field plot
• Voltage \(V\)
• Displacement field \((D)\)
• Electric energy \((W_e)\)
• Force \((F)\)
• Net current flow
• Power loss
• Current density \((J)\)
• Resistance and capacitance matrices of electrodes - \(R\) and \(C\) matrices

Meshing
• Adaptive strategy determines where refinements are needed after each step by:
  (i) Subdividing elements (2D/3D)
  (ii) Increasing the polynomial order (3D)
  (iii) Both techniques combined (3D)
• Mesh layers for skin depth analysis and highly anisotropic volume elements
• Extensive manual meshing controls

Geometric Modeling
• 3D ACIS® Modeler
• DXF/SAT are imported natively
• IGES import/export available
• Full Boolean operations
• Multi-Sweep function for complex geometries
The following possibilities exist, but are not purchased:
• Pro/E, STEP, CATIA and Inventor import/export modules

Materials Library
• Pre-defined library of linear, nonlinear and anisotropic materials
• User-defined conductivity/resistivity, permittivity and other parameters
• Supports anisotropic permittivity and conductivity

**Parametric Modeling**
• Perform multiple experiments for "What if?" analysis
  Any quantity can be parameterized (e.g. geometric features, materials, mesh settings) and can be varied through a user-specified range of values

**Scripting**
• Automate repetitive tasks using Visual Basic Script programming
• Link to third party software such as Excel or Matlab
• Customize ElecNet

**Basic equations, solved by ElecNet**

1. **Electrostatic field**

   The electrostatic field is called the field created by static charged particles, which charges are constant in time. Its equations can be derived from the full Maxwell system of equations for motionless media, when \( \frac{\partial \mathbf{B}}{\partial t} = 0 \) and \( \frac{\partial \mathbf{D}}{\partial t} = 0 \) are substituted, because of the static character of the field. Besides, currents are not present because the charged particles are immobile, and thus \( \mathbf{J} = 0 \).

   The only sources of the electrostatic field are the charges of the charged particles. In this case there is no connection between the electric and magnetic quantities and thus, the electrostatic and the magnetostatic fields can be analyzed independently.

   Thus, the equations of the electrostatic field are:

   \[
   \begin{align*}
   \text{rot } \mathbf{E} &= 0 \\
   \text{div } \mathbf{D} &= \rho \\
   \mathbf{D} &= \varepsilon \mathbf{E}
   \end{align*}
   \]

   The following notations are used here:
   \( \mathbf{E} \) – Electric field intensity
   \( \mathbf{D} \) – Electric flux density
   \( \varepsilon \) - permittivity
   \( \rho \) - charge density

   The equation \( \text{rot } \mathbf{E} = 0 \) shows, that the electrostatic field is a potential field. For potential fields, a scalar function \( V(x, y, z) \) can be introduced, called electric potential. It is defined as

   \[
   \mathbf{E} = -\text{grad } V,
   \]

   because it satisfies the equation \( \text{rot } \mathbf{E} = 0 \), since the vector identity \( \text{rot } \text{grad } V = 0 \) holds true.

   It is known from the mathematical physics, that the solution of the equations (1-3) is not unique. These equations are supplemented by boundary conditions for the quantities \( \mathbf{D} \) и \( \mathbf{E} \) on the interface between two media having different electrical properties. Using these boundary conditions, a unique solution of the electrostatic field equations can be found.
The main task of the Electrostatics is to find the distribution of the electric potential $V$ and the electric intensity $E$ in every point of the field, given the charges or potentials of the charged bodies. Using the voltage or electric field intensity distribution, the picture of the electrostatic field can be plotted. Also, integral quantities like capacitances, energies or forces can be determined, which is important practical task.

In the electrostatic problems, if charges are confined to the surfaces of conductors and insulators, so that there is no free charge within the volume of a material, the equation (2) reduces to:

$$\text{div } D = 0$$

(5)

To solve this equation, we first use Eq. 3 and the use Eq. 4 to express the electric field intensity $E$ in terms of the electric potential $V$. Equation (5) then becomes

$$\text{div} (\varepsilon \text{grad } V ) = 0$$

(6)

which can be solved numerically using the finite element method to determine the electric field in the device.

The Eq. 2 has integral form, called Gauss’s Law

$$\int \int_D D \, ds = q$$

(7)

where $q$ is the charge of the particles, existing in the volume with area $S$. It is often used to calculate the capacitances of capacitors that have different kinds of symmetry (in this case the surface integral in Eq. 7 can be solved easily using analytical methods).

2. Electric field in conducting media

In the regions, where external electromotive forces do not exist, the field of the DC current is a potential field, for which $\text{rot } E = 0$. The potential and the electric field intensity are related by

$$E = -\text{grad } V$$

(8)

As the DC current is continuous, the field of such a current has no sources:

$$\text{div } J = 0$$

(9)

Using the differential form of the Ohm’s Law

$$J = \sigma E$$

(10)

it follows that

$$\text{div} (\sigma E) = 0$$

(11)

Here, $J$ is the current density and $\sigma$ is the conductivity of the medium.

After substitution of Eq. 4 in Eq. 11, we obtain

$$\text{div} (\sigma \text{grad } V ) = 0$$

Or, in other terms

$$\nabla (\sigma \nabla V) = 0,$$

(12)

These equations can be used to find the distribution of the electric field and the current densities in different conducting bodies – conductor bars, cables, fuses, sensors for Electrical Resistance
Tomography (ERT). The Resistance matrix can be calculated also for complex ERT sensors. For this aim, the *RLC matrix calculator* is used.

3. Time-harmonic problems

The current flow problems solved by ElecNet are essentially quasi-electrostatic problems, in which the magnetic field terms in Maxwell’s equations can be neglected, but in which the displacement current terms are preserved. Again using Maxwell’s equations, the electric and magnetic fields must obey:

\[
\text{rot } \mathbf{H} = \mathbf{J} + \frac{\partial \mathbf{D}}{\partial t} \quad (13)
\]

\[
\text{div } \mathbf{B} = 0 \quad (14)
\]

\[
\text{rot } \mathbf{E} = -\frac{ \partial \mathbf{B}}{\partial t} \quad (15)
\]

\[
\text{div } \mathbf{D} = \rho \quad (16)
\]

subject to the constitutive relations:

\[
\mathbf{J} = \sigma \mathbf{E} \quad (17)
\]

\[
\mathbf{D} = \varepsilon \mathbf{E} \quad (18)
\]

The divergence of (13) can be taken to yield:

\[
\text{div}(\text{rot } \mathbf{H}) = \text{div } \mathbf{J} + \frac{\partial \mathbf{D}}{\partial t} \quad (19)
\]

By application of the vector identity \((\text{div rot} \equiv 0)\), the left-hand side of (19) is zero, leading to:

\[
\text{div } \mathbf{J} + \frac{\partial \mathbf{D}}{\partial t} = 0 \quad (20)
\]

Again we introduce an electric potential \(V\), related to the electric field intensity \(E\), by the relation \(E = \text{grad } V\).

Because the flux density \(B\) is assumed to be negligibly small, (14) and (15) are suitably satisfied by this choice of potential.

If a phasor transformation is assumed, the differentiation with respect to time is replaced by multiplication by \(j \omega\), and the \(E\) vector can be substituted into (20) to yield:

\[
\text{div } \mathbf{J} + j \omega \varepsilon \sigma \text{grad } V = 0 \quad (21)
\]

This equation can be used for computing the electric field in lossy dielectrics, where both parameters are present – permittivity \(\varepsilon\) and conductivity \(\sigma\), for low frequency excitation. This is the case in finding the impedances in the Electrical Impedance Tomography (EIT).

4. Finding capacitances

The capacitance is an integral characteristic of a capacitor, which is defined by the ratio of the absolute value of the charge on one of the electrodes to the absolute value of the potential difference between the electrodes of a capacitor:

\[
C = \frac{q}{u} \quad (22)
\]

The capacitance is measured in Farads \([C] = \text{F}\).

Using the electrostatic field quantities, the capacitance can be defined also as
The capacitance does not depend on the voltage or on the charge, because their ratio is a constant. The capacitance is a function only to the physical dimensions of the system and the permittivity of the dielectric.

One of the ways for determining the capacitance of a capacitor is to express the voltage between the capacitor plates by using their charge, and applying Eq. 22. Another way is to apply Eq. 23, computing the charge and the voltage between the plates using the electric field intensity.

The capacitance of a lonely conducting body is defined by the ratio between the charge and the potential of the body:

\[ C = \frac{q}{V} \]  \hspace{1cm} (24)

In this case the capacitance depends only on the shape of the body and the permittivity of the surrounding medium.

The resulting capacitance of two parallel connected capacitors is the sum of their capacitances:

\[ C = C_1 + C_2 \]  \hspace{1cm} (25)

The resulting capacitance of two series connected capacitors can be found using the formula

\[ \frac{1}{C} = \frac{1}{C_1} + \frac{1}{C_2}, \text{ or } C = \frac{C_1C_2}{C_1 + C_2}. \]  \hspace{1cm} (26)

If a system having more than two charged bodies is considered, the partial capacitances between each couple of electrodes must be defined.

The calculation of the capacitances of complex two-electrodes or multi-electrode systems is important practical task. Nowadays, it is solved successfully using numerical methods and CAD systems like ElecNet, Comsol, etc.

In the following lines three simple examples of analytical capacitance calculation will be considered.

**Example 1:** Capacitance of parallel-plate capacitor

The capacitor has distance between the plates \( a \), area of every plate \( s \) and permittivity of the dielectric \( \varepsilon \).

The Gauss Law in integral form is used, to express the relation between the electric field intensity and the charge on the plates, and then, the voltage between the plates is computed.

\[ \oint_{(s)} D \, ds = \varepsilon E s = q \Rightarrow E = \frac{q}{\varepsilon s} \]
\[ \begin{align*}
\int u = \int_0^a E \, dl = \frac{qa}{\varepsilon s} \\
\therefore \quad C = \frac{q}{u} = \frac{\varepsilon s}{a}
\end{align*} \tag{27} \]

From this example it is seen, that the capacitance of the parallel plate capacitor is proportional to the permittivity of the dielectric \( \varepsilon \) and to the area of the plates \( s \), and inversely proportional to the distance between the plates \( a \).

It is accepted here, that the electric field between the electrodes is uniform, and outside the electrodes it is equal to zero (that is, distortion of the field lines near the ends of the electrodes is missing. In reality, the distortion will be small if the width of the electrodes is much bigger than the distance between them.

**Example 2:** Capacitance of cylindrical capacitor with radiiuses \( R_1 \) and \( R_2 \) and length \( l \).

The Gauss Law in integral form is used:

\[
\iiint_{(s)} D \, ds = \varepsilon E 2\pi rl = q \quad \Rightarrow \quad E = \frac{q}{2\pi \varepsilon lr}
\]

\[
\begin{align*}
u = \int_{R_1}^{R_2} E \, dr &= \frac{q}{2\pi \varepsilon l} \int_{R_1}^{R_2} \frac{dr}{r} = \frac{q}{2\pi \varepsilon l} \ln \frac{R_2}{R_1} \\
\therefore \quad C = \frac{q}{u} = \frac{2\pi \varepsilon l}{\ln \frac{R_2}{R_1}}
\end{align*} \tag{28} \]

**Example 3:** Capacitance of spherical capacitor with radiiuses \( R_1 \) and \( R_2 \).

The Gauss Law in integral form is used:

\[
\iiint_{(s)} D \, ds = \varepsilon E 4\pi r^2 = q \quad \Rightarrow \quad E = \frac{q}{4\pi \varepsilon r^2}
\]

\[
\begin{align*}
u = \int_{R_1}^{R_2} E \, dr &= \frac{q}{4\pi \varepsilon} \int_{R_1}^{R_2} \frac{dr}{r^2} = -\frac{q}{4\pi \varepsilon} \left( \frac{1}{R_1} - \frac{1}{R_2} \right) = \frac{q}{4\pi \varepsilon} \left( \frac{1}{R_1} - \frac{1}{R_2} \right) \\
\therefore \quad C = \frac{q}{u} = \frac{4\pi \varepsilon R_1 R_2}{R_2 - R_1}
\end{align*} \tag{29} \]

These analytically computed capacitances will be compared with the capacitances found by ElecNet and the accuracy of ElecNet computations will be evaluated.

The capacitances in ElecNet are computed by finding the charge on every electrode (it is one of the ElecNet’s output quantities) and then dividing it to the voltage between the electrodes (Eq.22). This operation is made easy by the extension module *RLC-matrix calculator*. 

7
Main steps in using ElecNet

ElecNet is a software package that computes the electric field distribution by the Finite Element Method (FEM). In the FEM, the region under analysis is subdivided to elementary subregions, called elements, which in most of the cases are triangles (for 2D problems) or tetrahedra (for 3D problems). The unknown distribution of the potential is approximated by simple polynomials inside the elements, and the nodal values of the potential are taken as unknowns. For every element local matrices are built using this polynomial representation, and then the local matrices are assembled in one global matrix, valid for the whole region. The unknowns in this matrix are the nodal values of the potentials in the region. Solving the system, which is linear when linear materials are used, or non-linear, when non-linear materials are used, will give the unknown potential distribution. Using the potentials in the nodes, the electric field intensities can be found in every element, and then, many global quantities like charges on the electrodes, capacitances, electric energy, power, forces between electrodes, etc., can be found. Increasing the number of nodes in the region allows more accurate solution of the problem to be found, as the approximated potential distribution will be more close to the real distribution.

The main steps in application of the FEM using ElecNet are as follows:

1. Build geometric model
   a. Set the drawing space
   b. Draw the geometry
   c. Sweep the components

2. Add boundary conditions
   a. Draw and sweep an air box that surrounds the model
   b. Apply boundary conditions to the surfaces of the air box

3. Customize mesh (optional)
   a. Modify the mesh edge subdivisions
   b. Modify the element edge length

4. Solve (this step creates the finite element mesh, creates the global FE matrix and solves it)
   a. Choose the solver options (or accept the defaults)
   b. Choose the adaption options (optional)
   c. Start the appropriate for the problem solver

5. View the solution results
   a. View field plots and field animations
   b. View and graph global quantities
   c. Probe field values

This chapter will show how to use ElecNet to model simple electrostatic devices: cylindrical and parallel plate capacitors, using 2D FEM analysis.
The objectives are as follows:

- To examine the electric field and potential in the space between the conductors.
- To determine the capacitance of the capacitors.
- To improve the accuracy of capacitance calculation using finer mesh or higher order of elements.

**First example** – Cylindrical capacitor with two layers of dielectric. The outer layer dielectric has relative permittivity \( \varepsilon_{r1} = 2.5 \) and the inner layer dielectric has relative permittivity of \( \varepsilon_{r2} = 3.5 \). The radiiuses are: \( r_1 = 1 \text{mm} \), \( r_2 = 2 \text{mm} \), \( r_3 = 3 \text{mm} \), and the length of the capacitor is \( l = 10 \text{mm} \).

The pictures of the electric field lines and the equipotential lines are to be found. The capacitance of the capacitor is sought.

As the electric field in the cross-section of the capacitor is the same along the whole length, a 2D analysis will be performed. We will accept that the inner electrode has potential \( V_1 = 1 \text{V} \) and the outer electrode has potential \( V_2 = 0 \text{V} \).

At the end, different sizes and different order of elements will be used to improve the accuracy of capacitance calculation.

![Fig. 1: The capacitor cross-section](image)

This example has analytical solution, which gives the capacitances as follows:
For the outer layer:

\[ C_1 = \frac{2\pi \varepsilon_1 \varepsilon_0 l}{\log\left(\frac{r_1}{r_2}\right)} = 3.4301 \cdot 10^{-12} \text{ F} \]

For the inner layer

\[ C_2 = \frac{2\pi \varepsilon_2 \varepsilon_0 l}{\log\left(\frac{r_2}{r_1}\right)} = 2.8091 \cdot 10^{-12} \text{ F} \]

As the two dielectric layers are series connected, the equivalent capacitance is

\[ C = \frac{C_1 C_2}{C_1 + C_2} = 1.5443 \cdot 10^{-12} \text{ F} \]

This analytic result will be used to estimate the accuracy of capacitance calculation using ElecNet.

**Brief description of the Device Model**

Modeling the system involves the following steps:

- Draw the cross-section of the capacitor
- Extend it in a straight line to form a solid body, and specify the material.
- Specify the electrodes.
- Define the bounded region of the problem as an air box within which the field will be calculated.
- Instruct the program to solve the equations and display the results.

These steps are described in detail in the next sections.

**Getting started**

The instructions given below assume that you are familiar with Microsoft Windows, that you have installed ElecNet (The ElecNet v.7.1, 64-bit, is installed on the TOMOKIS server) and started the application by double-clicking the ElecNet icon.

The ElecNet Main window, shown below, should be visible.
1. Examine the ElecNet Main window, and identify the parts listed below.
   - The Project window displays information about the model, with tabs at the top labeled Object, Material, Electrode, Field, etc.
   - The View window is the work area where you construct the model and view the results.
   - Between the Project window and the View window is a vertical toolbar with buttons for selecting and viewing objects.
   - At the top of the Main window, there is the usual menu bar and one horizontal toolbar.

2. Click the View all icon in the Main window (or double-click the left mouse button), so that the window fills the screen.

3. Move the pointer to find the vertical split bar between the Project window and the View window. The pointer changes to a split symbol.

4. Drag the split bar to the right a short distance, and release it.
   - Repeat until all the tabs are visible at the top of the Project window.

5. Move the pointer over the buttons on the toolbars, pausing on each for the screen tip that describes the action of the button.
   - All of the toolbar buttons are duplicated on the menus. For example, the Edit menu gives access to the same selecting tools as the buttons on the vertical toolbar.

**Building the model**

In ElecNet, the default units of length are meters. For this example it is more convenient to work with dimensions in millimeters. Proceed as follows to change the default units and grid settings.

**Initial settings**

1. On the File menu, click New. Alternatively, click the New button.
2. On the File menu, click Save. Alternatively, click the Save button.
   - Select or create a suitable folder for storing the model.
3. Save the model with the name **Capacitor1**.  
*The model name in the Object page should change to Capacitor1.*

4. On the **Tools** menu, click **Set Units** to display a dialog:

5. Click the Length drop-down list.  
   * Select Millimeters.

6. Click OK to close the dialog.

7. On the View menu, click **Set Construction Grid** to display a dialog:

8. Set the Extent and Spacing values as follows:
   * Minimum X: –5  
   * Maximum X: 5  
   * Minimum Y: –5  
   * Maximum Y: 5  
   * X spacing: 1  
   * Y spacing: 1

9. Click OK.

**Displaying the grid**

Display the whole of the construction grid as follows.

1. On the View menu, click Construction Grid.  
*You should see a grid of a few very small points, widely spaced.*

2. Click the Examine Model button in the top of the vertical bar.

3. In the View window, roll the mouse wheel downwards to zoom out, so that more of the grid is visible.
Repeat as required until the whole grid is visible. If you zoom too much, roll upwards to zoom in.

If this is unsuccessful, click the View All button to restore the original view, and then zoom again.

**Drawing the outer electrode of the capacitor**
The default drawing mode is **Snap to Grid**, which means that lines, arcs and circles drawn with the mouse will lock to the grid points. Drawing tools can be activated from buttons on the horizontal toolbar, as shown in the instructions, or selected from the Draw menu.

In ElecNet, all drawing takes place on a 2D *construction slice*. For 2D models, this is just the $x$-$y$ plane, but for 3D models the construction slice can be moved to other planes.

1. Let first draw the outer circle having radius 3 mm. Click the **Add Circle** button.
2. Click first with the mouse left button when the mouse pointer is close to the point (0,0) – the center of the circle. Then drag the mouse, so the pointer points to (3,0) of the circle and click again with the left mouse button. A circle will appear after the first click, so you can watch how the size of the circle varies with the mouse move. The coordinates of the point to which the mouse pointer shows are shown on the status bar at the bottom of the screen. *The coordinate values will change in steps of 1 mm as the pointer moves near to successive grid points.*

If, by some reason, the circle is not correct, it can be deleted. Use the following steps:
- Press Esc to stop circle or line drawing.
- The circle or line must be selected using **Edit/Select Construction Slice Edges**, or using the button.
- Click the circle or line that you want to delete. *The selected line should turn red.*
- Use **Edit/Delete** or the key Delete from the keyboard, to delete the selected items.
- Then, click Add Circle to redraw the circle

3. In a similar way draw the circle with radius $r = 2$ mm, with two clicks, near the points (0,0) and (2,0)
4. In a similar way draw the circle with radius $r = 1$ mm, with two clicks, near the points (0,0) and (1,0)

The finished capacitor cross-section should look like this:
Create two new materials

We need to create two new dielectric materials for the two layers of dielectric. This is necessary, because the needed dielectrics with relative permittivities 2.5 and 3.5 do not exist in the standard Material library.

For the first dielectric material:
1. On the Tools menu, click New User Material
2. On the General page, enter the following data:
   - Name: **EP2.5: Relative permittivity 2.5**
   - Display color: Click Display Color and select an appropriate color
   - Description: Optional
   - Categories: Optional
3. Click Next
4. On the options page, select the following:
   1. Electric - Permittivity/Linear – isotropic, real
5. Using the Next button to advance to the appropriate pages, enter the following values:
   2. Temperature Celsius = 20
   3. Relative Permittivity = 2.5
6. Once you have entered all the values, click Finish to create the new material.
7. On the File menu, click Save

For the second dielectric material:
1. On the Tools menu, click New User Material
2. On the General page, enter the following data:
   - Name: **EP3.5: Relative permittivity 3.5**
   - Display color: Click Display Color and select an appropriate color
   - Description: Optional
• Categories: Optional
3. Click Next
4. On the options page, select the following:
   • Electric - Permittivity/Linear – isotropic, real
5. Using the Next button to advance to the appropriate pages, enter the following values:
   • Temperature Celsius = 20
   • Relative Permittivity = 3.5
6. Once you have entered all the values, click Finish to create the new material.
7. On the File menu, click Save

Completing the outer layer of the capacitor
1. Click the Select Construction Slice Surfaces button.
2. Click anywhere inside the outer layer.
   The interior of the outer layer should fill with a red pattern.
3. Click the Make Component in a Line button to display a dialog:

   ![Make Component In A Line dialog]

4. Change the Name from Component#1 to Layer1
5. Click the Material drop-down list.
6. Scroll down through the list and select the material EP2.5: Relative permittivity 2.5
7. In the dialog box, change the Distance to 10 mm.
8. Click OK.
   A component named Layer1 should be shown in the Object page of the Project bar.
Making the capacitor inner layer

1. Click the **Select Construction Slice Surfaces** button.
2. Click inside the inner layer. *The interior of the inner layer should fill with a red pattern.*
3. Click the **Make Component in a Line** button.
4. Change the **Name** from **Component#2** to **Layer2**.
5. Click the **Material** drop-down list.
6. Scroll down through the list and select the material **EP3.5: Relative permittivity 3.5**
7. In the dialog box, leave the **Distance** to 10 mm.
8. Click **OK**.

*A component named Layer2 should be shown in the Object page of the Project bar.*

The Object page of the Project bar should show two components: Layer1 and Layer2.

*If the name of a component is wrong, you can edit the name in the Object page by selecting the name and pressing F2.*

After this the model should look like:

---

**Defining the electrodes**

The next step is to specify that the capacitor inner and outer electrodes are equipotential, and to specify the voltage values.

This is accomplished by defining *electrodes*, which can be surfaces of components or entire components.

1. On the View menu, click **Rotate**, and then click **Rotate Dynamically**
2. Place the cursor over the model and rotate it to see the outer and inner surfaces of the electrodes
3. In the Object page, Select **Face#3** and **Face#4** of the **Layer1** component.
4. On the Model menu, click **Make Electrode**.
Electrode#1 should appear in the Object page.
5. In the Object page, Select Face#5 and Face#6 of the Layer2 component.
   Electrode#2 should appear in the Object page.
7. On the Object page, select Electrode#2
   Select the Electrode page of the Project bar, by clicking the Electrode tab.
   Electrode details should be displayed.
8. In the list for Electrode#2, click on 0 V RMS
   Press F2.
   The display should change to an edit box displaying the number 0.
   Change 0 to 1 and press Enter.
9. Select the Object page of the Project bar, by clicking the Object tab.
   This displays the names of the model components again.
10. On the File menu, click Save, or click the Save button.
    It is good practice to save often, in case the program crashes.

Removing selections
After defining the electrodes in this way, part of the model will be selected in the View window. This can interfere with subsequent displays. The following is a simple way of removing all selections:
   • In the Object page of the Project bar, click the model name. The selection will disappear.

Air box
For this example air box is not necessary, as the electric field is concentrated between the two electrodes, and the remaining parts of the space need not to be discretized.

Solving the model – general information
  ElecNet uses the finite-element method of solving the electric field equations. This subdivides the model into small elements, forming a mesh that covers the entire region. The true field within each element is approximated by a polynomial in terms of the field values at a small number of points, and ElecNet solves for the unknown field values at these points for all the elements. Using first order polynomial gives linear interpolation between the field values at the vertices of the triangles.
The accuracy will be higher with a fine mesh or a high-order polynomial. By default, a first-order polynomial is used, which is fast but not very accurate.

Initial solution
1. On the View menu, click Initial 2D Mesh.
   This should show the default mesh that ElecNet uses to solve the field equations.
2. Set the polynomial order of the elements to 2nd order
   • On the Solve menu, click Set Solver Options to display a dialog:
• Increase the *Polynomial Order* from 1 to 2 by clicking the up arrow.
• Click OK.

3. On the Solve menu, click *Static 2D*. The Solver Progress dialog should appear briefly. When the solution is complete, the Post Processing screen should be displayed in the Main window.

4. Close the Post Processing bar as follows:
   • Click on the tab *View 1* on the status bar below the main window to hide the postprocessing window and to see the main view and the device picture.
   • The postprocessing window can be seen again clicking on the tab *Results* on the status bar

---

**Post-processing**

After a field solution has been obtained, other quantities can be calculated and displayed. This is termed *post-processing*. ElecNet has a Post Processing bar that displays global quantities such as force and charge. In addition, shaded color plots of the field can be displayed, and the mouse can be used to display field values at any point in the model.
Viewing the equipotential plot
1. Select the Field page of the Project bar by clicking the Field tab.

The Field page has tabs at the bottom for Contour, Shaded and Arrow. The Contour page is active by default.

2. Click V, and then click Update View.
The window should show contours of constant V – an equipotential lines plot. It should be similar to the plot below. The equipotential lines must be circular, but now they are not, because the solution is not very accurate at this stage.

Getting electric field strength values
1. In the Field page of the Project bar:
   • Click the Shaded tab
   • Click None
   • Click Update View.
   This should remove any shaded color background from the display.
2. Click |E| Smoothed, and then click Update View.
   This should show a shaded color plot of the electric field magnitude, superimposed on the equipotential plot.
3. On the vertical toolbar, click the Field Probe button.
   • Move the mouse pointer anywhere in the model region, but do not click.
   • The Status bar should show two values at the left-hand side: the voltage, and |E| Smoothed. These numbers are the values at the position of the mouse pointer.
   • Move the pointer without clicking, and observe the change on the Status bar.
4. Hold the mouse still, with the pointer anywhere in the model region, and click once.
   • A new area should appear below the View window, called the Text Output bar.
   • This displays the coordinates of the point, the voltage and the electric field magnitude.
   • Every click in the model region displays a new set of values.
5. Close the Text Output bar by clicking this item on the Tools menu, or clicking the Hide box on the left-hand side of the bar.

Global quantities
The Post Processing bar has pages for displaying the calculated values of the global quantities: energy, force, charge and voltage for the model. Numerical results given below were obtained with version 7.1 of ElecNet. If you cannot see the displayed values, do the following.
   • Move the pointer to find the split bar between the Post Processing bar and the Keyboard Input bar.
The pointer changes from an arrow to a split symbol.

- Drag the split bar upward a short distance and release it. Repeat until the value is visible.
- You may also need to drag the text panels in the Post Processing bar.

Energy
By default, the Post Processing bar should display the Energy page. If this is not visible, click the Energy tab. The displayed value should be similar to the following:

![Energy Image]

Charge and capacitance
In the Post Processing bar, click the Charge tab. The displayed values of the charge should be similar to the following:

![Charge Image]

These values should be equal and opposite; the small difference in the magnitudes is an indication of errors in the numerical solution. The capacitance of the system may be calculated from the average magnitude of the charges of the electrodes and the voltage between them (1 V in the present case):

\[ C = \frac{q}{u} = 1.524979 \cdot 10^{-12} \text{ F} \]

Alternatively, the capacitance may be calculated from the stored electric energy:

\[ W_e = \frac{1}{2} Cu^2 \quad \Rightarrow \quad C = \frac{2W_e}{u^2} \]

But, as the voltage between the electrodes is \( u = V_1 - V_2 = 1 - 0 = 1 \text{ V} \), so

\[ C = 2W_e = 1.524978 \cdot 10^{-12} \text{ F} \]

The analytical result for the capacitance of this capacitor is \( C = 1.5443 \cdot 10^{-12} \text{ F} \), so the obtained by ElecNet value is not very accurate (with 1.25% relative error), because of the coarse mesh.

Improving the solution accuracy
To improve the solution accuracy, the size of the elements can be diminished, or the polynomial order of the elements can be increased.
The polynomial order of the elements can be increased as follows.

1. On the Solve menu, click Set Solver Options to display a dialog:
   - Increase the Polynomial Order from 2 to 3 by clicking the up arrow.
   - Click OK.

2. On the Solve menu, click Static 2D.

   When the solver finishes, the capacitance will be \( C = 1.521529 \times 10^{-12} \) F, which is not more accurate than before (1.47% relative error), even worse. The reason is that the mesh is too coarse.

3. Save the model again.

Refining the mesh

Increasing the polynomial order has not made improvement of the accuracy. The real problem is that the mesh is too coarse in parts of the model. The easiest way to refine the mesh is to specify the maximum size of the elements.

1. In the Object Page select Capacitor1
   - Right click with the mouse over Capacitor1 and select Properties
   - Choose the Mesh Tab, and mark Maximum element size – then specify value 0.1

2. Click OK

3. On the Solve menu, click Set Solver Options and set the Polynomial order back to 2, also select Improve the quality of the initial mesh before solving.
4. On the Solve menu, click Static 2D. The resulting plot should resemble the diagram below. The equipotential lines are nearly perfect circles, which shows the good accuracy. Let us read the charges again and to compute the capacitance:

![Table showing charges](image)

The computed capacitance in this case is

\[ C = 1.54328 \cdot 10^{-12} \text{ F} \]

which differs only by 0.066% from the analytic solution. The new mesh and the new equipotential lines are shown on the next figures:

4. Examine the change in the mesh as follows.
   - On the View menu, click Solution Mesh. This should show the refined mesh.
5. Save the model again.

**Displaying the electric field intensity vectors**

1. In the Field page of the Project bar:
   - Click the Arrow tab
   - Click E from the list
   - Some adjustment of the arrows must be done also

In the View page of the Project bar:
• Double click the Arrow Plot
• Click the Styles tab
  In the list Style choose: Basic
  In the Color choose: Specified color, and the black color from pallet
  In the Head length choose 20%
  Leave Tail length choose 0%
  Leave Angle to 15%
  Leave Anchor 50%
• Click Size tab
• In Maximum size choose x3
• OK
• Click Update View.

*This should show an arrow plot of the electric field vectors, superimposed on the equipotential plot and the color plot of the field magnitude.*
Solution accuracy considerations:

There are small discrepancies between the charge values on the two electrodes, which indicate errors in the numerical solution. To reduce the errors, the solution can be repeated after making each of the following changes:

- In the Solver Options dialog, reduce the CG tolerance from 0.01% to 0.001%.
- In the Adaption Options dialog, if it is used, change the tolerance from 0.5% to 0.05%.

Reducing the CG tolerance will reduce the discrepancy between the magnitudes of the charges on the two electrodes. It is generally advisable to make this change from the default CG tolerance of 0.01%.

SECOND EXAMPLE

Parallel-plate capacitor with one layer of dielectric having relative permittivity $\varepsilon_r = 3$ will be modeled and analyzed. The dimensions are: width $W = 5\,\text{cm}$, height of the dielectric and the plates $H = 1\,\text{cm}$ and the length of the capacitor is $L = 10\,\text{cm}$. The capacitor is placed in air. The pictures of the electric field lines and the equipotential lines are to be found. The capacitance of the capacitor is sought. The results from ElecNet must be compared to the analytically found capacitance.

As the electric field in the cross-section of the capacitor is the same along the whole length (except in the end regions in the front and in the back of the capacitor), a 2D analysis will be performed.

We will accept that the lower electrode has potential $V_1 = 0\,\text{V}$ and the upper electrode has potential $V_2 = 1\,\text{V}$. 

![Diagram of a parallel-plate capacitor with a dielectric layer](image-url)
At the end, different sizes and different order of elements will be used to improve the accuracy of capacitance calculation. Two additional guarding electrodes will be placed also, to diminish the fringing of the field lines and to improve the accuracy.

The parallel-plate capacitor has analytical solution for the capacitance, which is:

\[ C = \frac{\varepsilon_r \varepsilon_0 S}{H} = 13.281 \cdot 10^{-12} \text{ F} \]

where \( S = W \cdot H = 5 \text{ cm}^2 \) is the touching the dielectric area of one plate.

This analytic result will be used to estimate the accuracy of capacitance calculation using ElecNet.

**Building the model**

In this example, the units are in cm. As the default units are meters, these have to be changed to cm.

**Initial settings**

1. On the **File** menu, click **New**. Alternatively, click the New button.
2. On the **File** menu, click **Save**. Alternatively, click the Save button.
   - Select or create a suitable folder for storing the model.
   - Save the model with the name **Capacitor2**.
3. On the **Tools** menu, click **Set Units** to display a dialog:
4. Click the **Length** drop-down list.
   - Select Centimeters.
5. Click **OK** to close the dialog.
6. On the **View** menu, click **Set Construction Grid** to display a dialog:
7. Set the Extent and Spacing values as follows:
   - Minimum X: –10  Maximum X: 10
   - Minimum Y: –10  Maximum Y: 10
   - X spacing: 0.5  Y spacing: 0.5
8. Click **OK**.

**Displaying the grid**

Display the whole of the construction grid as follows.
- On the View menu, click **Construction Grid**.

**Drawing the lower electrode of the capacitor**

The coordinates of the points of the lower electrode can be entered by pointing and clicking with the mouse, but also by entering the numeric values, using the Keyboard Input Bar. This time we will use the second way.

1. Activate **Tools/Keyboard Input Bar**.
2. Click the **Add Line** button.

   ![Image of Keyboard Input Bar with X, Y: (0, 0)]
3. Move the mouse pointer in the Keyboard Input Bar and click with the mouse left button. Delete the values (0,0) that exist there and enter the coordinates of the first point -2.5, -1.5. Hit Enter on the keyboard to accept the values. Then enter the second point coordinates 2.5, -1.5 in the Keyboard Input Bar and hit Enter. As a result, a horizontal line will appear on the screen.

4. Enter the coordinates 2.5, -0.5 of the third point of the rectangle and hit Enter. The second line will be drawn, from the last point entered to this point.

5. Enter the coordinates -2.5, -0.5 of the fourth point of the rectangle and hit Enter. The third line will be drawn, from the last point entered to this point.

6. Enter the coordinates -2.5, -1.5 of the first point of the rectangle and hit Enter. The fourth line will be drawn, from the last point entered to this point.

With this, the rectangle of the lower electrode will be completely drawn, and hit Esc on the keyboard to stop the line draw.

**Drawing the upper electrode of the capacitor**

1. Click the Add Line button.

2. Enter the coordinates of the first point -2.5, 0.5 of the rectangle. Hit Enter on the keyboard to accept the values. Then enter the second point coordinates 2.5, 0.5 in the Keyboard Input Bar and hit Enter. As a result, a horizontal line will appear on the screen.

3. Enter the coordinates 2.5, 1.5 of the third point of the rectangle and hit Enter. The second line will be drawn, from the last point entered to this point.

4. Enter the coordinates -2.5, 1.5 of the fourth point of the rectangle and hit Enter. The third line will be drawn, from the last point entered to this point.

5. Enter the coordinates -2.5, 0.5 of the first point of the rectangle and hit Enter. The fourth line will be drawn.

6. Hit Esc on the keyboard to stop the line draw. With this the rectangle of the upper electrode will be completely drawn.

**Drawing the dielectric rectangle**

As the upper and the lower horizontal lines of this rectangle are drawn already, only the left and the right vertical lines have to be drawn.

1. Click the Add Line button.

2. Enter the coordinates of the first point -2.5, -0.5 of left vertical line of the rectangle. Hit Enter on the keyboard to accept the values. Then enter the second point coordinates -2.5, 0.5 in the Keyboard Input Bar and hit Enter. As a result, the left vertical line will be drawn.

3. Hit Esc on the keyboard to stop line draw.

4. Click the Add Line button.

5. Enter the coordinates of the first point 2.5, -0.5 of the right vertical line of the rectangle. Hit Enter on the keyboard to accept the values. Then enter the second point coordinates 2.5, 0.5 in the Keyboard Input Bar and hit Enter. As a result, the right vertical line will be drawn.

6. Hit Esc on the keyboard to stop the line draw.

**Completing the lower electrode of the capacitor**
1. Click the Select Construction Slice Surfaces button.
2. Click anywhere inside the lower electrode.
   The interior of the lower electrode should fill with a red pattern.
3. Click the Make Component in a Line button.
4. Change the Name from Component#1 to Plate1.
5. Click the Material drop-down list.
6. Scroll down through the list and select the material Aluminum: 3.8e7 Siemens/meter
7. In the dialog box, change the Distance to 10 cm.
8. Click OK.
   A component named Plate1 should be shown in the Object page of the Project bar.

Completing the upper electrode of the capacitor

1. Click the Select Construction Slice Surfaces button.
2. Click anywhere inside the upper electrode.
   The interior of the upper electrode should fill with a red pattern.
3. Click the Make Component in a Line button.
4. Change the Name from Component#2 to Plate2.
5. Click the Material drop-down list.
6. Scroll down through the list and select the material Aluminum: 3.8e7 Siemens/meter
7. In the dialog box, leave the Distance to 10 cm.
8. Click OK.
   A component named Plate2 should be shown in the Object page of the Project bar.

Making the capacitor dielectric layer

1. Click the Select Construction Slice Surfaces button.
2. Click inside the dielectric layer.
   The interior of the inner layer should fill with a red pattern.
3. Click the Make Component in a Line button.
4. Change the Name from Component#3 to Dielectric.
5. Click the Material drop-down list.
6. Scroll down through the list and select the material EP03: Relative permittivity 3
7. In the dialog box, leave the Distance to 10 mm.
8. Click OK.
   A component named Dielectric should be shown in the Object page of the Project bar.

After this the model should look like this:
Defining the electrodes
The next step is to specify that the capacitor inner and outer electrodes are equipotential, and to specify the voltage values. This is accomplished by defining electrodes, which can be surfaces of components or entire components.

1. In the Object page, select Plate1 component.
2. On the Model menu, click Make Electrode.
   Electrode#1 should appear in the Object page.
3. In the Object page, select Plate2 component.
   Electrode#2 should appear in the Object page.
5. On the Object page, select Electrode#2
6. Make right mouse click over Electrode#2 and choose Properties,
   Electrode details should be displayed.
7. In the Voltage field specify 1 V RMS
8. Click OK
9. On the File menu, click Save, or click the Save button.

Drawing the air box

An outer boundary is added to the model by creating a new component called air box, which encloses all the other components. The default boundary condition for the air box is Flux Tangential, which means that the electric field is constrained to be parallel to this boundary. This is a reasonable approximation if the boundary is sufficiently far away from the device. It is usually satisfactory to make the radius of the air box about 10 times the radius of the rest of the model.

Since the air box is much larger than the capacitor, it is not convenient to draw it with the mouse. Instead, coordinates are entered with the keyboard as described below.

If the air box is made in the same way as the other components, it will contain holes corresponding to the shapes of those components. This is undesirable, because it will cause problems later when the model is modified. To prevent holes being formed, an option must be selected in the Make Component in a Line dialog, as described in step 10 below.
1. On the View menu, click **Update Automatically**, or use the button on the vertical toolbar. 
   This adjusts the window to view all of the components.
2. On the Tools menu, click **Keyboard Input Bar** if there is no check mark beside it. 
   The Keyboard Input bar should be displayed at the bottom of the Main window, above the Status bar, with a text box for entering coordinates.
3. Click the **Add Circle** button .
   The Status bar at the bottom of the window should show:
   “Specify the center point and a point on the radius of the circle…”
4. Click in the text box of the Keyboard Input bar. 
   - If the co-ordinates are not shown as (0, 0), edit the text.
5. Press **Enter**, or click the Enter button at the end of the Keyboard Input bar. 
   The text next to the Enter button should change to (0, 0).
6. Change the co-ordinates in the text box to (10, 0). Press **Enter**, or click the Enter button. 
   The text next to the Enter button should change to (10, 0). A circle of radius 10 cm should be shown in the View window.
7. Press Esc to terminate circle drawing.
8. Click the **Select Construction Slice Surfaces** button .
9. Click anywhere inside the circle.
10. Click the **Make Component in a Line** button to make the air box. 
    - Enter the **Name** as **Air box**.
    - For the **Material**, select **AIR**.
    - The **Distance** should be 10 cm.
    - **Ignore Holes** must be selected. If the check box is empty, click the box.
    - Click **OK**.
11. On the File menu, click **Save**, or click the Save button.
    Over the air box, boundary conditions will not be specified explicitly, because for the air box, the default boundary condition is Flux Tangential (electric field will be parallel to this boundary).

**Solving the model**

**Initial solution**
Specify the mesh size limit:
1. In the Object page, Select **Capacitor2** model.
2. Right click over it and select **Properties**
3. Select the **Mesh** tab
4. Mark **Maximum element size** and specify value of 0.5 cm
5. Select **Close**
Specify the element order:
1. Select **Solve/Set SolverOptions…**
2. Specify **Polynomial order** to 2
3. Mark the choice: **Improve the quality of initial mesh before solving**
Solve the problem:
1. On the **Solve** menu, click **Static 2D**.
The Solver Progress dialog should appear briefly. When the solution is complete, the Post Processing screen should be displayed in the Main window.

2. Click on the tab View 1 on the status bar below the main window to hide the postprocessing window and to see the main view and the device picture.

Post-processing

Viewing the equipotential plot
1. Select the Field page of the Project window by clicking the Field tab.
2. In the Contour tab, click V, and then click Update View.

Getting electric field intensity picture
1. In the Field page of the Project window click the Shaded tab
2. Click $|E|$ Smoothed, and then click Update View.

To zoom the picture, press CTRL and select a rectangle with the mouse, clicking on the left upper point, dragging and releasing the mouse left button in the right lower point. The selected region will be shown at the full screen.

Find capacitance
In the Post Processing bar, click the Charge tab. The displayed values of the charge should be
Electrode#1: 1.50016e-11
Electrode#2: -1.50019e-11

These values should be equal and opposite; the small difference in the magnitudes is an indication of errors in the numerical solution. The capacitance of the system may be calculated from the average magnitude of the charges of the electrodes and the voltage between them (1V in the present case):
\[ C = \frac{q}{u} = 15 \cdot 10^{-12} \text{ F} \]

The analytical result for the capacitance of this capacitor is \( C = 13.281 \cdot 10^{-12} \text{ F} \), so the obtained by ElecNet value differs by 12.94% from the analytical value.

The reasons for the discrepancies can be:
1) the mesh is not sufficiently fine;
2) in the ElecNet model there exists fringing electric field, which is not taken into account in the analytical formula.

The capacitance can be found also using a specific ElecNet module (also named extension), called “RLC-matrix calculator”. It has advantages in finding the capacitance matrices of complex electrode systems with many electrodes. The RLC-matrix calculator can be started as follows:

1. From the Extensions menu, click RLC Matrix Calculator to display the Matrix Calculator dialog:

2. Set options as follows:
   - Solution Type: 2D
   - Solution Matrices: Capacitance
   - Number of Electrodes: 2
   - Set the name and the path of the output file
3. Click **Go**.
   - In the Save Now ? dialog, click Yes.
   - When the calculation is complete, capacitance values are displayed in the upper part of the dialog.

### CAPACITANCE MATRIX

**Electrodes index legend**

<table>
<thead>
<tr>
<th>Electrode Name</th>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electrode#1</td>
<td>1</td>
</tr>
<tr>
<td>Electrode#2</td>
<td>2</td>
</tr>
</tbody>
</table>

**Capacitance Matrix (all values are in Farads)**

<table>
<thead>
<tr>
<th></th>
<th>C1</th>
<th>C2</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>-3.03177880916314E-16</td>
<td>1.50016557966306E-11</td>
</tr>
<tr>
<td>C2</td>
<td>3.0317788090662E-16</td>
<td>1.50016557966306E-11</td>
</tr>
</tbody>
</table>

It can be seen that the capacitance between electrodes 1 and 2 is \( C_{12} = 1.5 \cdot 10^{-11} = 15 \) pF, the same as in the previous method.

**Improving the solution accuracy**

To improve the solution accuracy, and thus, the capacitance, the size of the elements can be diminished, or the polynomial order of the elements can be increased.

**Specify the mesh size limit:**

1. In the Object page, select **Capacitor2** model.
2. Right click over it and select **Properties**
3. Select the **Mesh** tab
4. Mark **Maximum element size** and specify value of 0.1 cm (5 times smaller elements)
5. Select **Close**

**Specify the element order:**

1. Select **Solve/Set SolverOptions…**
2. Specify **Polynomial order** to 4
3. Mark the choice: **Improve the quality of initial mesh before solving**

**Solve the problem:**

1. On the **Solve** menu, click **Static 2D**.

**Charge and capacitance**

In the Post Processing bar, click the **Charge** tab. The displayed values of the charge should be

- **Electrode#1**: \(-1.4984e-11\)
- **Electrode#2**: \(1.4985e-11\)

The capacitance of the system will be
\[ C = \frac{q}{u} = 14.9845 \cdot 10^{-12} \text{ F} \]

The obtained capacitance is not much better, so the difference with the analytical value is not due to the mesh and the polynomial order, but to the presence of fringing electric field in the ElecNet solution, which is not present in the analytical solution (there, the capacitor is ideal, without fringing).

In order to diminish the fringing, the capacitor model must be changed, to ensure that the electric field is strictly perpendicular to the electrodes. This can be done by diminishing the dielectric height, and also by putting guarding electrodes on the two sides of the upper electrode. For example, if we diminish the dielectric height, this will diminish the fringing, and the capacitance, found by ElecNet will be closer to the analytical value.

E.g., if \( H=1\text{mm} \) instead of \(1\text{cm} \), the analytical value of the capacitance will be \( C=132.81 \text{ pF} \), the capacitance from ElecNet will be 135.71 pF (el. size=0.1 cm and el. order=4) and the relative error will be 2.19 %. With the coarser mesh - el. Size=0.5 cm and el. Order=2, the C will be 136.08pF and the relative error 2.46 %.

The capacitor model with the guarding shields is shown at the next two figures. The role of the two guarding shields is to preserve the field below the main electrode homogeneous, not allowing curving and distorting the field lines. For this aim, the guarding shields have the same potential as the main upper electrode, which capacitance is calculated or measured.
The capacitance found for the upper main electrode by ElecNet is $C=13.6509\,\text{pF}$, with relative error 2.785 % (el. size=0.1 cm and el. order=4). This error is considerably lower than the error of 12.94% of the capacitor without guarding electrodes.

Further improvement of the accuracy can be obtained if the dielectric thickness is smaller. This will diminish the fringing additionally and the error can be reduced to 1 %.

Further improvement for this design cannot be obtained, as at the back sides of the electrode plates there is also some small charge, which cannot be diminished because there exists some small field there. It can be diminished by introducing grounded shields on the back sides of the electrodes.